This project has moved. For the latest updates, please go here.

can i run openhistorian under mono deployment?

Dec 24, 2014 at 3:50 AM
Hi:
I compiled openhistorian by vs2012,and it can run on windows.
Then i wanna try to make openhistorian run under mono deployment on linux, but it failed even if the GSF was replaced by a mono version.
I can't find any infomation about openhistorian running on mono,so ask for help.
If it can run on mono, and how?
Thanks!
Coordinator
Jan 5, 2015 at 2:02 PM
This is the source code for the new 2.0 version of the openHistorian.

The 1.0 historian can be found in the Grid Solutions Framework and works fine under Mono - see GSF.Historian. I'll write up some documentation and post in the GSF web site to help people get kick started with Linux.

The new 2.0 openHistorian should be able to support Mono as well but this hasn't been tested yet on Linux and will at least initially be limited to little-endian architectures - however the system is designed to accommodate big-endian architectures, this will just take a little time to implement these changes.

Thanks!
Ritchie
Coordinator
May 5, 2015 at 9:34 PM
For more information on running the 1.0 historian under Mono using the openPDC, see here:

https://openpdc.codeplex.com/wikipage?title=Running%20openPDC%20on%20Linux%20and%20Mac

Thanks,
Ritchie